ページ

2016年9月6日火曜日

【R】 パッケージ管理方法など

installation - How should I deal with "package 'xxx' is not available (for R version x.y.z)" warning? - Stack Overflow
Rのパッケージ管理 (アップデート 、読込済みパッケージ一覧の表示方法) - Qiita

Rを使っていて、パッケージがうまくインストールできないことがある。例えば、

Warning message:
package 'foobarbaz' is not available (for R version x.y.z)

という警告が出る場合。原因の一つにR本体のバージョンが低く、最新版を入れれば治ることがある。


そんなときには、

library(installr)
updateR()

を試してみると良い。上のコマンドupdateR()は簡単にRを最新版に変えてくれるもの。

片や、パッケージ側を最新版にしたい時もある。その場合は、

update.packages()

を試してみると良い。